СвязьПроект
Форум профессионалов связи
СвязьПроект - ваш надежный партнер в реализации сложных проектов

NAT Addpac APOS G2

(модели: IP100; IP150; IP200; AP100; VP200; VP300; VP350)
Исходные данные:

Внешний (public) IP-адрес AddPac X.X.X.X маска Z.Z.Z.Z (IP-адрес маршрутизатора X.X.X.1)
Внутренний (private) адрес AddPac (он же IP-адрес маршрутизатора для внутренней сети) — 10.0.10.1 маска 255.255.255.0

В зависимости от модели и версии APOS настройка NAT будет незначительно отличаться.

AddPac> enable
AddPac# configure terminal
AddPac(config)# ip routing

Настройки Ethernet интерфейса, подключенного к Internet (в данном примере – Ethernet 0 0; в терминологии AP100 – “LAN0”; в терминологии VP200, VP300, VP350 – “LAN”):

AddPac(config)# interface FastEthernet 0/0
AddPac(config-if)# ip address X.X.X.X Z.Z.Z.Z
AddPac(config-if)# ip nat outside
AddPac(config-if)# speed auto
AddPac(config-if)# ip route 0.0.0.0 0.0.0.0 X.X.X.1

Настройки Ethernet интерфейса, подключенного к Private сети (в данном примере – Ethernet 0 1; в терминологии AP100 – “LAN1”; в терминологии VP200, VP300, VP350 – “PC”):

AddPac(config)# interface FastEthernet 0/1
AddPac(config-if)# ip address 10.0.10.1 255.255.255.0
AddPac(config-if)# ip nat inside
AddPac(config-if)# speed auto

Необходимо разрешить доступ для всех адресов относящихся к Private сети:

AddPac(config)# access-list 100 permit ip 10.0.10.0 0.0.0.255 any
AddPac(config)# ip nat inside source list 100 interface FastEthernet0/0 overload

Сохранение конфигурации:

AddPac# write

Для доступа к сервисам оборудования, находящегося в Private (LAN) сети, необходимо в nat-list указать IP адрес оборудования и используемые сетевые порты. Пример: для обеспечения доступа к HTTP серверу, находящемуся в Private (LAN) сети необходимо ввести следующую команду:

AddPac(config)# ip nat inside source static tcp 10.0.10.3 80 interface FastEthernet0/0 80

где 10.0.10.3 - IP-адрес HTTP сервера.

Для получения информации о текущей конфигурации NAT, воспользуйтесь командами:

AddPac# show ip nat arp
AddPac# show ip nat statistics
AddPac# show ip nat translations

Для диагностики работы NAT, воспользуйтесь командами:

AddPac# debug ip nat translations
AddPac# debug ip nat detail


Сайт поддерживается компания «ИМАГ».
© 2011-2019 EMAG.
Все пpава защищены
Решения|Проекты|Оборудование|ТехПоддержка|Технологии|Обучение