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ISM Provision 
Installing ISM Provision
Overview

The Infrastructure and Services Management Provision (ISM Provision) suite of 
applications consist of the ISM Provision server, device communicator, and two 
application clients. These components can be installed on separate hosts or combined. 
Typically, the database server and device communicator will be installed on one host 
(generally, a more powerful machine on the network), and the clients will be installed 
on other hosts (generally those used by the people responsible for managing the 
network).

As you use ISM Provision you may later decide to add additional device 
communicators to other hosts in your network to share the processing load of 
communicating with your network devices. You may also decide to install additional 
application clients to allow others to help manage the network. The heart of your ISM 
Provision, the server, will continue to reside on one host in your network.

ISM Provision components can be installed on Solaris or Windows platforms, and the 
components will interoperate across different platforms.

System Requirements

The minimum Windows platform requirements to install and run any of the ISM 
Provision components are the following: 

• Operating system—Windows 2000 or Windows XP
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• Processor— 800 Mhz Pentium III

• Memory—256 Mb RAM

• Disk Space—200 Mb free 

• Graphics—16 bit color, resolution 1024 by 768

The ISM Provision server component has higher resource requirements:

• Memory—512 Mb

The minimum Solaris requirements to install and run ISM Provision components are the 
following: 

• Operating system—Solaris 8

• Processor—Ultra 10, single CPU

• Memory—512 Mb RAM

• Disk Space—200 Mb free 

• Graphics—16 bit color, resolution 1024 by 768

The ISM Provision server component has higher resource requirements:

• Memory—1 Gb RAM

This Document

This document is split into two sections, one section for Windows platforms, one for 
Solaris. Most actions for the two platforms are similar, but they differ enough to need 
separate instructions. In the Windows Platform section you will find:

• Installing ISM Provision on a Windows Platform, page 1-3

• Using ISM Provision under Windows, page 1-16

• Uninstalling ISM Provision From Windows, page 1-19

In the Solaris Platform section you will find:

• Installing ISM Provision on a Solaris Platform, page 1-23

• Using ISM Provision under Solaris, page 1-35

• Uninstalling ISM Provision From Solaris, page 1-38
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To install ISM Provision on a Windows platform, see the section “Windows Platform” 
on page 1-3. To install ISM Provision on a Solaris platform, see the section “Solaris 
Platform” on page 1-23.

Windows Platform

For the Windows installation you will need the ISM Provision CDROM, and license 
keys to activate the ISM Provision server. If you do not have the license keys, you can 
still install the other components, and you can still install a limited evaluation version 
of the ISM Provision server. There is a license key for the number of nodes (devices) 
managed by the ISM Provision server and another license key for the number of 
subscribers.

Installing ISM Provision on a Windows Platform

Summary Steps.  To install ISM Provision on a Windows platform:

1 Insert the ISM Provision CDROM

2 Activate the Setup Program

3 Choose Product Features

4 Enter License Keys

5 Accept the License Agreement

6 Choose Install Folder

7 Choose Server

8 Complete the Installation

Detailed Steps.  The following steps are a more detailed explanation of the previous 
section.

To install ISM Provision on a Windows platform:

1 Insert the ISM Provision CDROM

Insert the ISM Provision CDROM into the drive that you will use for installation.
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2 Activate the Setup Program

You can activate the setup program by navigating to and double-clicking its icon. 
You will find the program, “setup.exe”, on your CDROM drive in the folder 
“Windows”.

Alternately, you may go to the Windows Start menu and select Run... Enter the 
setup program location into the Open: field of the Run dialog box. For example, if 
your CDROM drive letter is D:, you will type:

D:\Windows\setup.exe

Once you’ve typed in the program location, select Ok to activate the program.
1-4 ISM Provision Installation Guide



ISM Provision 

Windows Platform
Once you activate the setup program, you will see a dialog box with the message 
“InstallAnywhere is preparing to install...” Once the InstallAnywhere application 
finishes preparation, the ISM Provision Installation wizard dialog box will appear.

Select Next to move to the next screen. During the remainder of the installation, after 
entering information into an installation wizard screen, select Next to move to the 
next screen.
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3 Choose Product Features

When the Choose Product Features dialog box appears you will either choose one of 
the ISM Provision component groups to install, or select Custom Install to install a 
combination of components on a single host. At a minimum, you must install an 
ISM Provision server, a device communicator, and a NIM client somewhere on your 
network, in order to use ISM Provision. We recommend that you install the Server 
group first on your server machine. This will install the server and a device 
communicator on the server machine. The NIM and IPSM clients can be installed on 
the same machine, or on others in your network.

Choose the component by clicking the icon, or if you will install more than one 
component group, choose the Custom icon. 
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If you choose the Custom icon, the Choose Product Features box will change to a 
listing of the available components and check boxes for selecting the components to 
install.

Select the components to install by clicking the checkboxes, or by using the 
pull-down menu in the Feature Set field. You can check more than one box at a 
time. If you select the Clients checkbox, you will install both clients.
Installation Guide 1-7



Installing ISM Provision
Once you have selected the product features to install, the installer will check if any 
of the components you plan to install were previously installed. If a previously 
installed component is detected, you are prompted to allow the installed to uninstall 
the previously installed one, to cancel the installation, or to go back and specify a 
different group of components to install.
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4 Enter License Keys

If you selected the ISM Provision server as one of the components to install, you will 
need to enter license keys, one key for nodes (devices), one key for subscribers. The 
License Key screen will not appear if you do not install the ISM Provision server. 

Enter the license keys in the fields, then select Next. You will be presented with the 
license agreement screen. Continue the installation from the section “Accept the 
License Agreement” below.

No License Key.  If you do not have one or both license keys, select Next, and you will 
see the Invalid Node License message box and the message, “Proceed with 
Evaluation.” If you select OK you will be given an evaluation license for nodes. You 
will see the same sequence for the Invalid Subscriber License message box. If you 
choose Cancel, you will cancel the installation.
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The evaluation licenses are of limited duration. You cannot change any of the 
parameters of these licenses.
1-10 ISM Provision Installation Guide



ISM Provision 

Windows Platform
5 Accept the License Agreement

Select the radio button to accept the license agreement. If you choose not to accept 
the license agreement, the installation wizard will cancel the installation.
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6 Choose Install Folder

Choose the folder for the installation. If the default is not acceptable, use the Choose 
button to select another folder.
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7 Choose Server

If you install a device communicator without installing the ISM Provision server, you 
will be asked to specify the host where the ISM Provision server will be installed. 
Enter the hostname or IP address of the server host.

You will not see the Choose Server screen if you are not installing a device 
communicator, or if you are installing the device communicator and the server 
together on the same host. When they are installed on the same host, the installation 
wizard will automatically configure the device communicator to connect to the sever 
on that host.
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8 Complete the Installation

Once the components are selected and you have moved to the next installation 
wizard screen, the installation will continue. New files will be added and the 
registry will be updated. During installation you will see the Installing ISM 
Provision screen.

The installation wizard reports the progress of the installation until it completes. At 
completion, you will see the Install Complete screen of the installation wizard.
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The installation wizard will tell you where ISM Provision has been installed. If there 
have been any problems detected by the installation wizard, it will display 
suggested remedies to complete the installation. Select Done to close the installation 
wizard.
Installation Guide 1-15



Installing ISM Provision
Using ISM Provision under Windows

Information about using ISM Provision can be found in the document Network 
Infrastructure Manager User Guide. You will find the document in the help subdirectory 
of the ISM Provision installation directory. If you used the default installation directory, 
you will find the file in this directory:

C:\Program Files\Extreme Networks\ISM Provision\help

The PDF file, imclient.pdf, contains the user guide and can be viewed and printed with 
the Adobe Acrobat Reader, or other PDF applications. You can also access the document 
by selecting Help Topics from the Help menu in the NIM client. The other file, 
smclient.pdf, contains the document IP Services Manger User Guide. This is the guide for 
the IP Services Manger client for ISM Provision.

To use ISM Provision, you will start the ISM Provision server and device communicator, 
and then launch the NIM client. Once it has connected to the ISM Provision server, you 
can begin adding your existing network devices to the system as described in the user 
guide.

Starting the ISM Provision Server and Device Communicator

When the ISM Provision server is installed, it is set up by default to start automatically 
when you boot the system. If you have not rebooted since you installed the server, you 
will need to start it manually. Login to the host machine for the ISM Provision server 
and launch the Services tool.

1 From Windows, select Start>Settings>Control Panel (If you are using Windows XP, 
select Start>Control Panel). The Windows Control Panel should appear. 

2 Double-click the Administrative Tools icon. (If you are using Windows XP, you may 
not see this icon unless you also click the Performance and Maintenance icon.) 

3 From Administrative Tools, double-click the Services icon.

Once the Services tool has launched, look for an entry titled, “ISMP Server”. This entry 
tells you the status of the server. Highlight the entry and select the Action>Start menu 
item to start the server if it is not already started.

If you wish to modify the server properties, you can do it from here. Highlight the 
server entry and select the Action>Properties menu. You can change the server 
configuration from this tool.
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Using the same Services tool, look for the entry titled, “ISMP Device Communicator”. It 
should be located above the entry for the ISM Provision server, if you installed it on the 
same host as the server. Highlight this entry and select the Action>Start menu item to 
start the device communicator if it is not already started. 

If you did not install the device communicator on the server machine, you will need to 
launch the NIM client and add the device communicator hostname to the server. Follow 
the instructions in the next section, “Launching the NIM Client”, to launch the NIM 
client, and then follow the directions in the subsequent sections, “Add Device 
Communicator Hostname to Server” and “Start Device Communicator” to complete the 
process of using ISM Provision.

Launching the NIM Client

From Windows, select Start>Programs>Extreme Networks>Applications and choose 
Network Infrastructure Manager. The login screen requires you to enter the hostname 
or IP address of the ISM Provision server and a username and password. The default 
username is admin, and for the default password, leave the field blank. 

Starting the Device Communicator

If you installed the device communicator on a different host than the ISM Provision 
server, you will need to use the NIM client to add the device communicator hostname 
to the server. Without this, the server will not allow the device communicator to connect 
and the device communicator will eventually exit. If the server and device 
communicator are installed on the same host, the connection is managed automatically 
and you will not need to do the following steps.

Add Device Communicator Hostname to Server.  From the NIM client, select the 
menu View>Server Administration. When the Server Administration view appears, 
select the Add Device Communicator button (If the button is not visible, select the 
Communicators tab near the top of the view). Type the hostname into the Host Name 
field of the Create Device Communicator wizard, then select the Finish button near the 
bottom of the wizard. Your entry should appear on the screen, and its status will likely 
be displayed as “Not available” until you start the communicator.

Start Device Communicator.  Login to the host machine for the device communicator 
and start the device communicator. You will need to launch the Services tool.
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1 From Windows, select Start>Settings>Control Panel (If you are using Windows XP, 
select Start>Control Panel). The Windows Control Panel should appear. 

2 Double-click the Administrative Tools icon. (If you are using Windows XP, you may 
not see this icon unless you also click the Performance and Maintenance icon.) 

3 From Administrative Tools, double-click the Services icon.

Once the Services tool is running, start the ISM Provision device communicator. Look 
for an entry titled, “ISMP Device Communicator”. Highlight the entry and select the 
Action menu. Choose Start or Restart to run the device communicator.

Once the ISM Provision device communicator is running, the Server Administration 
view of your NIM client should display the status of the communicator as “Started”.
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Uninstalling ISM Provision From Windows
If you need to uninstall ISM Provision from your system, you should stop the ISM 
Provision server and device communicator, if present. Stopping the server and device 
communicator is almost identical to starting them. Use the procedure above, “Starting 
the ISM Provision Server and Device Communicator”, but instead of choosing 
Action>Start in the Services application, choose Action>Stop.

When ISM Provision is installed, an uninstall wizard is also added to your system. To 
launch the uninstall wizard, you can use the Windows Start>Programs menu, or use 
the standard Windows Control Panel application named Add/Remove Programs.

Launch Uninstall Using Windows Start>Programs Menu

From Windows, select Start>Programs>Extreme Networks>ISM 
Provision>Uninstall>Uninstall ISMP. The uninstall wizard will launch and begin the 
uninstall process. Continue with the section “Uninstallation Wizard” below.

Launch Uninstall Using Add/Remove Programs Application

From Windows, select Start>Settings>Control Panel. The Windows Control Panel 
should open. Double-click the Add/Remove Programs application icon to launch the 
program installer/uninstaller.
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Scroll until you can select the ISM Provision application. Once it is selected, a button 
appears to change or remove ISM Provision. Select the Change/Remove button to 
launch the uninstall wizard.

Uninstallation Wizard

The uninstallation wizard first asks you to confirm that you want ISM Provision 
removed from your system. Select Uninstall to remove ISM Provision or select Cancel 
to stop the uninstallation and close the wizard.

While it is uninstalling, the wizard will inform you of its status. It will remove any files, 
folders, or registry entries that were created during installation, but will not remove any 
files or folders created after installation. 

One folder used by ISM Provision that is not removed (and you did not explicitly 
create), is the folder named “.extremenetworks”. It is created in your home directory the 
first time you launch any of the ISM Provision clients. They will use this folder to store 
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your preferences. If you are planning to re-install ISM Provision or install a later 
version, you may want to retain this folder even after uninstalling ISM Provision.
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When finished, the wizard will show that the uninstall is complete. Select Quit to close 
the wizard.
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Solaris Platform

For the Solaris installation you will need the ISM Provision CDROM, and the license 
key to activate the ISM Provision server. If you do not have a license key, you can still 
install the other components, and you can still install a limited evaluation version of the 
ISM Provision server.

To install the ISM Provision server and device communicator you will write new files to 
the /etc/init.d directory, so you need administrator privileges to install these 
components. To install the clients, you need no special privileges, beyond the 
permissions to write files to the directory where you wish to install them. 

Installing ISM Provision on a Solaris Platform

Summary Steps.  To install ISM Provision on a Solaris platform:

1 Insert the ISM Provision CDROM

2 Activate the Setup Program

3 Choose Product Features

4 Enter License Keys

5 Accept the License Agreement

6 Choose Install Folder

7 Choose Server

8 Complete the Installation

Detailed Steps.  The following steps are a more detailed explanation of the previous 
section.

To install ISM Provision on a Solaris platform:.

1 Insert the ISM Provision CDROM

Insert the ISM Provision CDROM into the drive that you will use for installation.
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2 Activate the Setup Program

You can activate the setup program by navigating to and double-clicking its icon, 
using a graphical file manager. You will find the program, “setup.bin”, on your 
CDROM drive in the folder “Solaris”.

Alternately, you may activate the setup program from the command line. For 
example, if your CDROM drive is mounted at /dev/dsk/cdrom, you will type:

/dev/dsk/cdrom/Solaris/setup.bin

The first installer dialog box will appear with the message “ISM Provision preparing 
to install...”

Once the application finishes preparation, the ISM Provision Installation wizard 
dialog box will appear.
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Select Next to move to the next screen. During the remainder of the installation, after 
entering information into an installation wizard screen, select Next to move to the 
next screen.
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3 Choose Product Features

When the Choose Product Features dialog box appears you will either choose a 
single ISM Provision component to install, or select Custom to install a combination 
of components on a single host. At a minimum, you must install an ISM Provision 
server, a device communicator, and a NIM client somewhere on your network, in 
order for ISM Provision to work.

Choose the component by clicking the icon, or if you will install more than one 
component, choose the Custom icon. If you choose the Custom icon, the Choose 
Product Features box will change to a listing of the available components and check 
boxes for selecting the components to install.
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Select the components to install by clicking the checkboxes, or by using the 
pull-down menu in the Feature Set field. You can check more than one box at a 
time. If you select the Clients checkbox, you will install both clients.
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4 Enter License Keys

If you selected the ISM Provision server as one of the components to install, you will 
need to enter license keys, one key for nodes (devices), one key for subscribers. The 
License Key screen will not appear if you do not install the ISM Provision server. 

Enter the license keys in the fields, then select Next. You will be presented with the 
license agreement screen. Continue the installation from the section “Accept the 
License Agreement” below.

No License Key.  If you do not have one or both license keys, select Next, and you will 
see the Invalid Node License message box and the message, “Proceed with 
Evaluation.” If you select OK you will be given an evaluation license for nodes. You 
will see the same sequence for the Invalid Subscriber License message box. If you 
choose Cancel, you will cancel the installation. 
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The evaluation licenses are of limited duration. You cannot change any of the 
parameters of these licenses.
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5 Accept the License Agreement

Select the radio button to accept the license agreement. If you choose not to accept 
the license agreement, the installation wizard will cancel the installation.
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6 Choose Install Folder

Choose the folder for the installation. If the default is not acceptable, use the 
Choose... button to select another folder.
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7 Choose Server

If you install a device communicator without installing the ISM Provision server, you 
will be asked to specify the host where the ISM Provision server will be installed. 
Enter the hostname or IP address of the server host.

You will not see the Choose Server screen if you are not installing a device 
communicator, or if you are installing the device communicator and the server 
together on the same host. When they are installed on the same host, the installation 
wizard will automatically specify the local host as the server location. 
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8 Complete the Installation

Once the components are selected and you have moved to the next installation 
wizard screen, the installation will continue. New files will be added and the 
registry will be updated. During installation you will see the Installing ISM 
Provision screen.

The installation wizard reports the progress of the installation until it completes. At 
completion, you will see the Install Complete screen of the installation wizard.
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The installation wizard will tell you where ISM Provision has been installed. If there 
have been any problems detected by the installation wizard, it will display 
suggested remedies to complete the installation. Select Done to close the installation 
wizard.
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Using ISM Provision under Solaris

Information about using ISM Provision can be found in the document Network 
Infrastructure Manager User Guide. You will find the document in the help subdirectory 
of the ISM Provision installation directory. The PDF file, imclient.pdf, contains the user 
guide and can be viewed and printed with the Adobe Acrobat Reader, or other PDF 
applications. You can also access the document by selecting Help Topics from the Help 
menu in the NIM client.

To use ISM Provision, you will start the ISM Provision server and device communicator, 
and then launch the NIM client. Once it has connected to the ISM Provision server, you 
can begin adding your existing network devices to the system as described in the user 
guide.

Starting the ISM Provision Server and Device Communicator

When the ISM Provision server is installed, it is set up by default to start automatically 
when you boot the system. If you have not rebooted since you installed the server, you 
will need to start it manually. Login to the host machine for the ISM Provision server 
and open or launch a command line window. From the command line you will run the 
ISM Provision server script. You will pass the parameter “start” to the script, named 
ismp in the /etc/init.d directory. So, you will type the following:

/etc/init.d/ismp start

to start the server and device communicator (if installed together). To verify that the 
server has started, type the following command:

ps -e | grep server

If the server is running, this command will return output similar to the following:

5827 pts/6      0:00 server

showing that the process called “server” is currently running. If the server is not 
running, then the command will return no output.

Use a similar process to check if the device communicator process, called “devcomm”, 
is currently running. Type the following command:

ps -e | grep devcomm

and look for output similar to this:
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5828 pts/6      0:00 devcomm

If you did not install the device communicator on the server machine, you will need to 
launch the NIM client and add the device communicator hostname to the server. Follow 
the instructions in the next section, “Launching the NIM Client”, to launch the NIM 
client, and then follow the directions in the subsequent sections, “Add Device 
Communicator Hostname to Server” and “Start Device Communicator” to complete the 
process of using ISM Provision.

Launching the NIM Client

You can launch the NIM client by navigating to and double-clicking its icon, using a 
graphical file manager. You will find the program, “nim”, in the bin subdirectory of the 
ISM Provision installation directory (typically, /opt/extreme/ismprov).

Alternately, you may launch the NIM client from the command line. For example, if 
your ISM Provision installation directory is /opt/extreme/ismprov, you will type the 
following command:

/opt/extreme/ismprov/bin/nim

Once you’ve launched the NIM client, you will see the login screen. The login screen 
requires you to enter the hostname or IP address of the ISM Provision server and a 
username and password. The default username is admin, and for the default password 
leave the field blank.

If you installed the device communicator on a different host than the ISM Provision 
server, you will need to use the NIM client to add the device communicator hostname 
to the server. Without this, the server will not allow the device communicator to connect 
and the device communicator will eventually exit. If the server and device 
communicator are installed on the same host, the connection is managed automatically 
and you will not need to do the following steps.

Add Device Communicator Hostname to Server.  From the NIM client, select the 
menu View>Server Administration. When the Server Administration view appears, 
select the Add Device Communicator button (If the button is not visible, select the 
Communicators tab near the top of the view). Type the hostname into the Host Name 
field of the Create Device Communicator wizard, then select Finish near the bottom of 
the wizard. Your entry should appear on the screen, and its status will likely be 
displayed as “Not available” until you start the communicator.
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Start Device Communicator.  Login to the host machine for the device communicator 
and start the device communicator. Use the same process as described above for starting 
the server, in other words, type the following command:

/etc/init.d/ismp start

to start the device communicator. To verify that the device communicator has started, 
type the following command:

ps -e | grep devcomm

and look for output similar to this:

5828 pts/6      0:00 devcomm

Once the ISM Provision device communicator is running, the Server Administration 
view of your NIM client should display the status of the communicator as “Started”.
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Uninstalling ISM Provision From Solaris

If you need to uninstall ISM Provision from your system, you should stop the ISM 
Provision server and device communicator, if present. Stopping the server and device 
communicator is almost identical to starting them. Use the procedure above, “Starting 
the ISM Provision Server and Device Communicator”, but instead of typing: 

/etc/init.d/ismp start

you will type:

/etc/init.d/ismp stop

When ISM Provision is installed, an uninstall wizard is also added to your system. To 
launch the uninstall wizard, you can use a graphical file manager or launch it from the 
command line.

Launch Uninstall Using Graphical File Manager

From your graphical file manager, navigate to the directory where ISM Provision was 
installed. From there, navigate to the “UninstallerData” subdirectory. Double-click the 
Uninstall_ISMP icon. The uninstall wizard will launch and begin the uninstall process. 
Continue with the section “Uninstallation Wizard” below.

Launch Uninstall from the Command Line

The executable that will launch the uninstall wizard is located in the “UninstallerData” 
subdirectory of the ISM Provision installation directory. The launcher is named 
“Uninstall_ISMP”. You can either change to the “UninstallerData” subdirectory and 
execute the launcher, or execute the launcher by entering its complete pathname. For 
example, if ISM Provision is installed in the “/opt/extreme/ismprov” directory, you 
would type the following:

cd /opt/extreme/ismprov/UninstallerData
./Uninstall_ISMP

or you would type the following:

/opt/extreme/ismprov/UninstallerData/Uninstall_ISMP

The uninstall wizard should now launch.
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Uninstallation Wizard

The uninstallation wizard first asks you to confirm that you want ISM Provision 
removed from your system. Select Uninstall to remove ISM Provision or select Cancel 
to stop the uninstallation and close the wizard.

While it is uninstalling, the wizard will inform you of its status. It will remove any files, 
folders, or registry entries that were created during installation, but will not remove any 
files or folders created after installation. 

One folder used by ISM Provision that is not removed (and you did not explicitly 
create), is the folder named “.extremenetworks”. It is created in your home directory the 
first time you launch any of the ISM Provision clients. They will use this folder to store 
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your preferences. If you are planning to re-install ISM Provision or install a later 
version, you may want to retain this folder even after uninstalling ISM Provision.
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When finished, the wizard will show that the uninstall is complete. Select Quit to close 
the wizard.
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